Hulp en ondersteuning

Snel zelf van start en antwoord op veel gestelde vragen.

  • Help
  • Overig
  • Wat zijn de systeemeisen voor Picqer?

Wat zijn de systeemeisen voor Picqer?

Om gebruik te maken van Picqer is het niet nodig dure servers te plaatsen of software te installeren. Picqer werkt volledig via internet, het enige wat je nodig hebt is een laptop of computer met internet en een recente browser.

Alle besturingssystemen

Het maakt niet uit met welk besturingssysteem je werkt. Mac, Linux, Windows, iOS of Android, wij ondersteunen het allemaal.

Alle bekende browsers

Picqer werkt met alle bekende browsers, zolang het maar een recente versie is. Dat betekent: de nieuwste versie en de versie daarvoor.

Op dit moment (januari 2018) betekent dat:

Browser Versies
Google Chrome 63, 62
Safari 11, 10
Firefox 57, 56
Microsoft Edge 16, 15

Internet Explorer

Internet Explorer is door Microsoft stopgezet en wordt niet meer actief ondersteund. Wel ondersteunen we de opvolger van Microsoft: de browser Edge.

Kunnen we je helpen?

Is je vraag niet beantwoord of heb je nog aanvullende vragen? We helpen je graag.

Bel ons op 085-3030690 of mail naar info@picqer.com.